485会收到自己发送的数据

使用的是UART1,发现会收到自己的数据(使用了9600bps,无流控)。

另一个FUART也是同样的电路,但是却可以正常收发。帮忙看看。

下面是原理图和dts(用的是你们提供的双网卡版本的):

pad配置:

                <PAD_FUART_RX    PINMUX_FOR_FUART_MODE_1 MDRV_PUSE_FUART_RX>,

                <PAD_FUART_TX       PINMUX_FOR_FUART_MODE_1     MDRV_PUSE_FUART_TX>,


                <PAD_UART1_RX         PINMUX_FOR_UART1_MODE_1       MDRV_PUSE_UART1_RX >,
                <PAD_UART1_TX         PINMUX_FOR_UART1_MODE_1       MDRV_PUSE_UART1_TX >,

这个是

        uart1: uart1@1F221200 {

            compatible = "sstar,uart";

            reg = <0x1F221200 0x100>;

            interrupts = <GIC_SPI INT_IRQ_UART_1 IRQ_TYPE_LEVEL_HIGH>;

            clocks = <&CLK_uart1>;

            status = "ok";

        };

        fuart: uart2@1F220400 {

            compatible = "sstar,uart";

            reg = <0x1F220400 0x100>, <0x1F220600 0x100>;

            interrupts = <GIC_SPI INT_IRQ_FUART IRQ_TYPE_LEVEL_HIGH>, <GIC_SPI INT_IRQ_URDMA IRQ_TYPE_LEVEL_HIGH>;

            clocks = <&CLK_fuart>;

            dma = <0>;

            sctp_enable = <0>;//rts cts enable is 1

            status = "ok";

        };



下面这个是会收到自己发的数据的:

attachments-2021-11-SnHgQ58z618c8defd679d.png


attachments-2021-11-ksOj4uwa618c8d94a23e3.png

attachments-2021-11-2H8Wwq9W618c8d9f9d2bd.png


另一个不会:


attachments-2021-11-qDhn1wtL618c8db3e5abe.png


attachments-2021-11-aUoJs1PG618c8dbd17e64.png


请先 登录 后评论

1 个回答

BBelephant

经测试没出现自发自收的情况。

请先 登录 后评论
  • 1 关注
  • 0 收藏,413 浏览
  • Tony 提出于 2021-11-11 11:30

相似问题